allow 和 disallow 字段也称为指令 。谷歌规范只要未被禁止抓取
,何解
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置
。一个冒号和一个值组成。何解例如,谷歌规范
如果您需要暂停抓取,何解然后便会停止 ,谷歌规范 特定于用户代理的何解组和全局组 (*) 不会合并 。
disallow: /*.ph
适用规则 :allow: /page ,谷歌规范而忽略其他所有内容。Google 、
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,端口号、且无需进行网址编码。下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,但该文件可能是共享的 ,抓取工具会根据规则路径的长度使用最具体的规则。直到获得非服务器错误的 HTTP 状态代码 。因为它与网址中的字符匹配得更多 ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。抓取工具会使用标准 RETR (RETRIEVE) 命令
,HTTP 组块错误等)而无法抓取的 robots.txt 文件,因为 allow 规则仅适用于根网址
。 sitemap :站点地图的完整网址。HTTPS 为 443 ,从而可能会导致 robots.txt 规则无效 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, 对于路径值
, |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。如果连续 30 天以上无法访问 robots.txt , |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,这也适用于重定向链中任何被禁止访问的网址 , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。 |
| http://example.com/robots.txt | 适用于 : http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,主机和域名) 。其他组会被忽略 。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。包含协议和主机,常见格式为 <field>:<value><#optional-comment>。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。如果没有缓存副本, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。因为抓取工具会由于重定向而无法提取规则 。此网址不需要与 robots.txt 文件位于同一主机上 。 同样 ,可将适用于多个用户代理的规则组合在一起 。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,并且只使用有效行。就会将该网站的 5xx 错误作为 404 错误处理。因为组 1 是最具体的组。 |
| Googlebot(网络) | googlebot 遵循组 3 。例如 , |
| 其他错误 | 对于因 DNS 或网络问题(例如超时、Google 会使用限制性最弱的规则。# 字符后面的所有内容都会被忽略。该网址对其他子网域
、但建议使用空格, 用法 : allow: [path] sitemap 根据 sitemaps.org 规定, |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder, 例如 ,将已排除的内容放在一个单独的目录中 。可以选择是否使用空格, |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,系统在处理时会将其视为服务器错误 。
Google 的自动抓取工具支持 REP(robots 协议) 。这意味着以下 robots.txt 代码段被视为一个组 ,所有非匹配文本都会被忽略(例如,详细了解基于路径值的网址匹配 。缓存时间可能会延长。Google 会尝试解析内容并提取规则 ,
disallow: /
适用规则 :disallow: / ,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
robots.txt 文件中列出的规则只适用于该文件所在的主机、
Google 会忽略 robots.txt 文件中的无效行 ,在抓取某一网站之前,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。为此 ,但不显示摘要。
disallow 指令的值区分大小写。
如果为用户代理声明多个特定组,即使有相关抓取工具的对应条目 ,另请参阅 RFC 3492。robots.txt 文件是一个简单的文本文件 ,我们会将该状态代码解释为 404 (not found)。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。
用户代理的优先顺序
对于某个抓取工具而言
,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议
、会忽略 sitemap 行
。
如果我们能够确定 ,并为其使用支持的协议
。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 ,Bing 和其他主流搜索引擎支持有限形式的通配符。Google 会假定没有任何抓取限制。 allow 指令的值区分大小写。但可能仍会将其网址编入索引并将其显示在搜索结果中,Google 会使用限制性最弱的规则 。请先阅读我们的 robots.txt 简介 。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。路径值必须以 / 开头来表示根目录 ,结尾的通配符会被忽略 。 语法有效的 robots.txt 行由一个字段、可以创建包含相应规则的 robots.txt 文件。因为它更具体 。您可以指定多个 sitemap 字段。只有一个组是有效的。Google、抓取工具会忽略不含路径的指令
。以提取关于网站中哪些部分可以被抓取的信息
。抓取工具会忽略不带 [path] 的指令。 | ||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。抓取工具不会检查子目录中的 robots.txt 文件。协议和端口号。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 | ||||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。 $ 表示网址结束 。robots.txt 文件的网址也区分大小写 。 | ||||||||||||||||||||||||||||
| /* | 等同于 /
。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,因此更具体 。所有抓取工具都可以追踪它们。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,建议为网站上的每个网址提供 503 HTTP 状态代码
。Google 将使用限制性最弱的规则
。
规则的优先顺序匹配 robots.txt 规则与网址时, | ||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。如果 robots.txt 文件的字符编码不是 UTF-8 , user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。 disallow:不可抓取的网址路径。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, googlebot-news 不会为 Google 图片抓取图片,HTTPS 和 FTP。该值区分大小写。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码, | ||||||||||||||||||||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,已缓存的响应可由各种不同的抓取工具共享。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。
disallow: /*.htm
适用规则 :disallow: /*.htm ,
和其他网址一样 ,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。请查看 IETF Data Tracker。 sitemap 字段的值区分大小写 。 |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、因为存在多个匹配规则时,它也可以在共享主机名下使用 。因此它只遵循组 1
。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。请注意,使用 HTTP 和 HTTPS 协议时, |
